Welcome to the The Garage Journal Board forums.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   The Garage Journal Board > The Garage > Free Parking

Sponsored Links (Register now to hide all advertisements)

Reply
 
Thread Tools Search this Thread Display Modes
Old 10-18-2011, 09:28 PM   #1
41ratrod
Senior Member
 
41ratrod's Avatar
 
Join Date: Aug 2010
Location: Springfield Mo.
Posts: 346
Default 1999 KIA SPORTAGE won't start.

My daughter has a 99 Kia and the check engine came on , but it was running
fine no miss or rough idle. So this morning .
6:30 AM after my wife left for work I drove it into the garage it started right up
and ran fine. I when back to bed.
8:30 Started it back up ran OK light was still on , so turned it off and pulled
cable off the battery to see if the light would come back on.
Now no start. Check the fuel pump and its running ,has new filter less then 6 months old.
2.0 DOHC
Has new timing belt.
new plugs and wires. All with less then a 1000 miles.
Since I pulled the battery cable the code reader shows no code.
It does crank over.
Where should I start next?

Last edited by 41ratrod; 10-19-2011 at 07:37 AM.
41ratrod is offline   Reply With Quote
Old 10-18-2011, 09:30 PM   #2
Garage5.9
Senior Member
 
Garage5.9's Avatar
 
Join Date: Jan 2011
Location: Maui,Hawaii
Posts: 2,169
Default Re: 1999 KIA SPORTAGE won't start.

The basics is where i would start , fuel pressure , spark and compression. IF its not something obvious like a loose battery connection , starter etc
Garage5.9 is offline   Reply With Quote
Sponsored Links (Register now to hide all advertisements)
Old 10-18-2011, 09:34 PM   #3
Garage5.9
Senior Member
 
Garage5.9's Avatar
 
Join Date: Jan 2011
Location: Maui,Hawaii
Posts: 2,169
Default Re: 1999 KIA SPORTAGE won't start.

oh yeah forgot to ask does it crank ?
Garage5.9 is offline   Reply With Quote
Old 10-18-2011, 09:45 PM   #4
MechanicNamedJohn
Senior Member
 
MechanicNamedJohn's Avatar
 
Join Date: Jun 2010
Posts: 1,182
Default Re: 1999 KIA SPORTAGE won't start.

Its most likely the crank position sensor, its a Hyundai, the CPS fails often.
__________________
Instagram: JohnnyOCD
MechanicNamedJohn is offline   Reply With Quote
Old 10-19-2011, 05:31 AM   #5
Drew_flux
Senior Member
 
Join Date: Dec 2009
Location: sydney Australia
Posts: 811
Default Re: 1999 KIA SPORTAGE won't start.

what indicator lights are displayed on combination meter with ignition on ? e.g. engine light,brake light. i wonder if you are having an immobilizer issue. also the AL sportage is the only car i have ever seen NOT START from a faulty/unpluged o2 sensor.
Drew_flux is offline   Reply With Quote
Old 10-19-2011, 06:38 AM   #6
mrholeshot
Senior Member
 
mrholeshot's Avatar
 
Join Date: Jun 2010
Posts: 8,052
Default Re: 1999 KIA SPORTAGE won't start.

Check under the bed to see if her boyfriend is hiding under there. masters of sabotage. lol
__________________
Try to be the person your dog thinks you are.
mrholeshot is offline   Reply With Quote
Old 10-19-2011, 06:50 AM   #7
41ratrod
Senior Member
 
41ratrod's Avatar
 
Join Date: Aug 2010
Location: Springfield Mo.
Posts: 346
Default Re: 1999 KIA SPORTAGE won't start.

Quote:
Originally Posted by Drew_flux View Post
what indicator lights are displayed on combination meter with ignition on ? e.g. engine light,brake light. i wonder if you are having an immobilizer issue. also the AL sportage is the only car i have ever seen NOT START from a faulty/unpluged o2 sensor.
It does cranks over and all normal lights are on when you turn the key on.
41ratrod is offline   Reply With Quote
Old 10-19-2011, 06:56 AM   #8
41ratrod
Senior Member
 
41ratrod's Avatar
 
Join Date: Aug 2010
Location: Springfield Mo.
Posts: 346
Default Re: 1999 KIA SPORTAGE won't start.

Quote:
Originally Posted by mrholeshot View Post
Check under the bed to see if her boyfriend is hiding under there. masters of sabotage. lol
Not a good place to hide a boyfriend she'd have to do some cleaning under it you may say its her SPORTAGE area.ha ha
41ratrod is offline   Reply With Quote
Old 10-19-2011, 07:01 AM   #9
Joelfke
Senior Member
 
Joelfke's Avatar
 
Join Date: Mar 2009
Location: Monroe Township, NJ
Posts: 1,757
Send a message via AIM to Joelfke Send a message via Yahoo to Joelfke
Default Re: 1999 KIA SPORTAGE won't start.

Quote:
Originally Posted by MechanicNamedJohn View Post
Its most likely the crank position sensor, its a Hyundai, the CPS fails often.
x2 on this. worked for a hyundai dealer. we do those crank sensors alllllll the time. if youre lucky its on the radiator side of the block. not sure what motor is in it. if youre unlucky its behind the timing belt
__________________
"The bolt doesn't really care who made your wrench, its going to be a stubborn prick reguardless"

Quote:
Originally Posted by Merkava_4 View Post
Sears = [fill in the blank] problem. :lol:
Joelfke is offline   Reply With Quote
Old 10-19-2011, 07:35 AM   #10
41ratrod
Senior Member
 
41ratrod's Avatar
 
Join Date: Aug 2010
Location: Springfield Mo.
Posts: 346
Default Re: 1999 KIA SPORTAGE won't start.

Quote:
Originally Posted by Joelfke View Post
x2 on this. worked for a hyundai dealer. we do those crank sensors alllllll the time. if youre lucky its on the radiator side of the block. not sure what motor is in it. if youre unlucky its behind the timing belt
2.0 DOHC I hope its not behind any covers .
41ratrod is offline   Reply With Quote
Old 10-19-2011, 08:06 PM   #11
41ratrod
Senior Member
 
41ratrod's Avatar
 
Join Date: Aug 2010
Location: Springfield Mo.
Posts: 346
Default Re: 1999 KIA SPORTAGE won't start.

Quote:
Originally Posted by 41ratrod View Post
2.0 DOHC I hope its not behind any covers .
found the problem had a bad connection in the wiring .
41ratrod is offline   Reply With Quote
Old 10-19-2011, 08:17 PM   #12
Original Man
Senior Member
 
Join Date: Feb 2011
Location: South Florida
Posts: 661
Default Re: 1999 KIA SPORTAGE won't start.

Where?
Original Man is offline   Reply With Quote
Old 10-19-2011, 09:04 PM   #13
41ratrod
Senior Member
 
41ratrod's Avatar
 
Join Date: Aug 2010
Location: Springfield Mo.
Posts: 346
Default Re: 1999 KIA SPORTAGE won't start.

Quote:
Originally Posted by Original Man View Post
Where?
Under the intake and above the starter there is four sets of wires w/connector
( the one on top on ours) had a bad connect .so cleaned it with contact cleaner. well get back into it this weekend and put some elect' type grease
had to remove the battery to get to them.
someone on the Kia Forum said to check this,had the same problem.
41ratrod is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Sponsored Links (Register now to hide all advertisements)


All times are GMT -5. The time now is 08:45 AM.