Welcome to the The Garage Journal Board forums.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   The Garage Journal Board > The Tools > General Tool Discussion

Sponsored Links (Register now to hide all advertisements)

Reply
 
Thread Tools Search this Thread Display Modes
Old 12-18-2011, 06:20 PM   #1
Lewisthepilgrim
Member
 
Join Date: Dec 2011
Posts: 37
Default Generator runs but no power!

Hey guys hows it goin. I have a 6k constant run(7200max) Campbel Hausfield Generator. Its powered by a 11hp Brigs and stratton.

The generator starts up RIGHT away and runs perfectly. BUT there is no power being produced. I have pulled the cover off the generator and checked for power, 1.4v is the most power being produced from any of the wires.

Where should I start looking? I'm assuming it could be brushes? Is there another place I should start? Are there any good links to generator repair ?

Thanks guys!
Lewisthepilgrim is offline   Reply With Quote
Old 12-18-2011, 06:39 PM   #2
rct
Member
 
Join Date: Jan 2011
Location: N Tonawanda, NY
Posts: 43
Default Re: Generator runs but no power!

I forget the exact way to do it (google it) but if it hasn't been run in a while try "flashing" the generator with a battery. A component may have lost magnetism. A bad diode is another possibility but try the flash first.

http://www.endtimesreport.com/dead_gen.html

Last edited by rct; 12-18-2011 at 06:45 PM. Reason: add link
rct is offline   Reply With Quote
Sponsored Links (Register now to hide all advertisements)
Old 12-18-2011, 06:42 PM   #3
box
Member
 
box's Avatar
 
Join Date: Oct 2011
Location: Toms River NJ
Posts: 81
Default Re: Generator runs but no power!

i assume you checked the basic's like fuses and breakers?

The brushes dont go bad until many many hours of use, i how old is it?
box is offline   Reply With Quote
Old 12-18-2011, 06:51 PM   #4
85camaro
Senior Member
 
Join Date: Nov 2011
Location: the valley of the sun
Posts: 288
Default Re: Generator runs but no power!

I had a Honda that would do that and it was because something got too much dirt/dust on it. I can't remember what exactly. minor problem though.
85camaro is offline   Reply With Quote
Old 12-18-2011, 07:05 PM   #5
TxPowderCoater
Member
 
Join Date: Nov 2011
Location: Cut N Shoot Texas
Posts: 81
Default Re: Generator runs but no power!

flash it with a drill motor
TxPowderCoater is offline   Reply With Quote
Old 12-18-2011, 07:41 PM   #6
Charles (in GA)
Senior Member
 
Charles (in GA)'s Avatar
 
Join Date: Jan 2006
Location: 50 mi south of Atlanta
Posts: 10,650
Default Re: Generator runs but no power!

Here 'ya go.....................

Thread about flashing generator
Charles (in GA) is offline   Reply With Quote
Old 12-18-2011, 09:07 PM   #7
GeorgiaHybrid
Senior Member
 
GeorgiaHybrid's Avatar
 
Join Date: Sep 2008
Location: Extreme NW Georgia
Posts: 3,765
Default Re: Generator runs but no power!

Sounds like you blew the voltage regulator. Have you ever started the generator with something plugged in and turned on? if yes, you will need to replace it. The typical voltage is from 1.4 to 2.5 volts at teh plug when they are blown.
GeorgiaHybrid is offline   Reply With Quote
Old 12-21-2011, 05:44 PM   #8
Lewisthepilgrim
Member
 
Join Date: Dec 2011
Posts: 37
Default Re: Generator runs but no power!

I tried re-magnetizing it with a drill, no dice.

Voltage regulator eh? Where is that located?
Lewisthepilgrim is offline   Reply With Quote
Old 12-21-2011, 05:54 PM   #9
GeorgiaHybrid
Senior Member
 
GeorgiaHybrid's Avatar
 
Join Date: Sep 2008
Location: Extreme NW Georgia
Posts: 3,765
Default Re: Generator runs but no power!

It should be a small circuit board on the end of the generator under the cover. Go buy a new one (they run about $50 to $75) and you should be able to see where it goes. You can also look at a parts breakdown of your generator to see where it goes.

What happens when you start a generator with a load attached, it will try to make 115 volts AC with the generator just barely turning over as you pull start or use the starter to crank it. It will blow trying to do that by over amping the regulator.

Always crank the generator, then apply the load. I try to do the same when stopping it, take off the load and shut it down.
GeorgiaHybrid is offline   Reply With Quote
Old 12-24-2011, 07:30 PM   #10
Lewisthepilgrim
Member
 
Join Date: Dec 2011
Posts: 37
Default Re: Generator runs but no power!

I will check it out thanks. I'm not sure mine has any boards, it seems like a rather simple generator.
Lewisthepilgrim is offline   Reply With Quote
Old 12-24-2011, 08:03 PM   #11
GeorgiaHybrid
Senior Member
 
GeorgiaHybrid's Avatar
 
Join Date: Sep 2008
Location: Extreme NW Georgia
Posts: 3,765
Default Re: Generator runs but no power!

It will have a regulator that is replaceable. I had to replace mine earlier this year after the tornado's hit due to the neighbor cranking mine while it was plugged in.
GeorgiaHybrid is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Sponsored Links (Register now to hide all advertisements)


All times are GMT -5. The time now is 09:46 AM.