Welcome to the The Garage Journal Board forums.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   The Garage Journal Board > The Garage > Heating and A/C

Sponsored Links (Register now to hide all advertisements)

Reply
 
Thread Tools Search this Thread Display Modes
Old 01-01-2011, 07:21 PM   #1
maxwedge
Member
 
Join Date: Feb 2010
Location: Bloomington IL
Posts: 36
Default Beacon Morris hanging heater problem/question

I have a two year old, 75KBTU, Beacon Morris hanging heater in my garage. I noticed when I was out there the last few days that it isn't always lighting on the fist try. I can hear the solenoid click then the spark fires for several seconds and then it stops, waits about 30 seconds and tries again, usually it lights on the second try with the distinctive woosh sound, but twice now it's gone three times. It seems that if it doesn't light on the third try , then it shuts off and you have to cycle the power off and back on, which I'm assuming is a safety feature. Any ideas on what might be causing this, or maybe simple fix of cleaning something? before I call it in?
maxwedge is offline   Reply With Quote
Old 01-01-2011, 07:25 PM   #2
rickairmedic
Senior Member
 
rickairmedic's Avatar
 
Join Date: May 2005
Location: louisville ,Ky
Posts: 4,167
Default Re: Beacon Morris hanging heater problem/question

Pull the burners out and give them a good cleaning with some compressed air and while your in there pull the flame sensor out and give it a good cleaning with some emery cloth or sandpaper.


Rick
rickairmedic is offline   Reply With Quote
Sponsored Links (Register now to hide all advertisements)
Old 01-01-2011, 11:58 PM   #3
Eggman
Member
 
Join Date: Dec 2010
Location: St. Louis
Posts: 31
Default Re: Beacon Morris hanging heater problem/question

Try using a dollar bill or a piece of scotchbrite. Sandpaper will take the coating off of a flame sensor which will ruin it.

Eggman
Eggman is offline   Reply With Quote
Old 01-02-2011, 10:38 AM   #4
joey d
Junior Member
 
Join Date: Nov 2008
Posts: 27
Default Re: Beacon Morris hanging heater problem/question

It might be the ignitor grounding out on the case. Had that problem with my beacon morris. Sounds like the same symptoms. Bend the ignightor housing just a touch to center it. Should clear up your problem.
joey d is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Sponsored Links (Register now to hide all advertisements)


All times are GMT -5. The time now is 07:54 AM.