Welcome to the The Garage Journal Board forums.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   The Garage Journal Board > The Garage > Heating and A/C

Sponsored Links (Register now to hide all advertisements)

Reply
 
Thread Tools Search this Thread Display Modes
Old 01-23-2011, 05:38 PM   #1
jherrman
Junior Member
 
Join Date: Jan 2011
Posts: 1
Default Modine heater burners won't light, but fan kicks on

I recently purchased a used, early 1990's, Modine overhead 75K btu gas heater (PAE75). When I first got it home before I hung it up I hooked it up and it took right off and blew good heat. This weekend I finally got it hung up and I so I wanted to test it out again to make sure everything was working and it took right off again, but after running about 15 minutes I noticed it was blowing cold air and after investigating the burners weren't lit any longer, but the fan was still running. Now no matter what I do the main burners won't light. The pilot light is lit and is a good strong flame, so that's not the issue. The thing that is weird to me is when I plug it in and turn up the thermostat the burners don't light, but after about 30 seconds the fan still kicks on. I thought most heaters had a sensor that made sure the burners were lit before the fan kicked on, which makes this case confuse me that much more. I don't really have any experience working on heaters, but I'm usually pretty good with anything mechanical, I just have no idea what could be wrong with this thing. I have checked all the wires and connections and everything seems solid. I have not yet vented it through my roof, as I want to make sure this thing is going to work before I do that, but that wouldn't be causing this problem would it? Does anyone have any idea what could possibly be going on with this heater? Any help or suggestions would be great.
jherrman is offline   Reply With Quote
Old 01-23-2011, 07:43 PM   #2
JoeyM
Junior Member
 
Join Date: Nov 2008
Posts: 17
Default Re: Modine heater burners won't light, but fan kicks on

Well it might be your main power is crossed feeding the heater, just unplug it and switch the wires.....

Hope this helps,
JoeyM is offline   Reply With Quote
Sponsored Links (Register now to hide all advertisements)
Old 01-23-2011, 08:16 PM   #3
MrBill
Junior Member
 
Join Date: Jan 2011
Posts: 3
Default Re: Modine heater burners won't light, but fan kicks on

Your heater has a timed on fan start. In other words the fan starts after a predetermined time. Here is the manual for your unit. The limit switch or flue blocked switch most likely have tripped causing the main valve not to be energized. Go to page 20 and you will see there location. You may have a access door or you may have to remove the entire panel to access those limits, they may have a button to reset them. Also follow the instructions for proper flue ventilation.
http://www.modineheaters.com/Modine-PAE-Manual.pdf
Hope this helps. email me if you need further help. I have been in the business for 30+yrs
MrBill is offline   Reply With Quote
Old 02-03-2012, 03:35 PM   #4
gogopntr
Junior Member
 
Join Date: Feb 2012
Posts: 1
Default Re: Modine heater burners won't light, but fan kicks on

just had mine fixed, there is a reset button on top of unit, take off cover and push it, it happens when a downdraft comes in thru the vent i guess. simple as that, ps i replaced the thermocoupler anyway hope that works. $65.00 for the repair but its 12 ft up and tight.

i figure its worth it garage wont freeze
gogopntr is offline   Reply With Quote
Old 02-03-2012, 06:24 PM   #5
dave67fd
Senior Member
 
dave67fd's Avatar
 
Join Date: Apr 2011
Location: Southern NH
Posts: 790
Default Re: Modine heater burners won't light, but fan kicks on

What is your gas source? Are you sure manifold, line pressure is correct? 75k BTU heater at 15 min is enough to drain a small source if thats what your using. Might be enough to keep pilot lit but not the burners.
__________________
Check out my Build at:
http://www.garagejournal.com/forum/s...d.php?t=102939
dave67fd is offline   Reply With Quote
Old 02-01-2014, 04:54 PM   #6
MrBillJr
Junior Member
 
Join Date: Feb 2014
Posts: 1
Default Re: Modine heater burners won't light, but fan kicks on

Quote:
Originally Posted by gogopntr View Post
just had mine fixed, there is a reset button on top of unit, take off cover and push it, it happens when a downdraft comes in thru the vent i guess. simple as that, ps i replaced the thermocoupler anyway hope that works. $65.00 for the repair but its 12 ft up and tight.

i figure its worth it garage wont freeze
Just wanted to say THANK YOU! This fixed my problem. Your instructions were right on. We had high winds last week when I was away, when I got back, fan was running with the gas valve locked out...No Heat. Thanks again guys.
MrBillJr is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Sponsored Links (Register now to hide all advertisements)


All times are GMT -5. The time now is 10:14 PM.